Web Reporting Issue


We're always open to a little constructive criticism.

Web Reporting Issue

Postby Icculus » Jun 12th, '10, 15:26

I placed an order more than a week ago and it is still shows on the website "Your order has been assembled and is waiting to be shipped"

A few days ago i sent an email using the online webform asking to either ship my order or cancel it and refund my credit card.. I consider it terrible customer server to not have a phone number anywhere to deal with issues like this.

**
edit.

I recieved the tea today and apparently the issue was just with the website reporting the order had not been shipped yet.
Last edited by Icculus on Jun 12th, '10, 20:25, edited 1 time in total.
Icculus
 
Posts: 2
Joined: Jun 12th, '

Re: Horrible Customer Service

Postby Chip » Jun 12th, '10, 15:41

Hi, welcome to TeaChat. I suspect a glitch in the system. I have contacted several people at Adagio.

Good luck!

Chip
Immoderate TeaDrinker who happens to Moderate ...
User avatar
Chip
Mod/Admin
 
Posts: 22184
Joined: Apr 22nd, '
Location: Back in the TeaCave atop Mt. Fuji

Re: Horrible Customer Service

Postby Mikael » Jun 12th, '10, 16:42

Wow. Im really sorry about that. We very rarely, if ever, have such issues with our system. Must be a glitch. :x And we usually respond right away to customer service emails. So I really apologize for that..

I looked up your order and I think the problem is that the California warehouse is missing an item. I could be wrong.. but I emailed the warehouse manager, so we should have everything fixed pronto... Shipped monday hopefully. Sorry again.

Once you get your tea, let us know if you like it and we'll send you a gift certificate. I hope you don't let this situation stop you from shopping with us again.

Update: Spoke with the California warehouse manager and your order was indeed shipped last week, but a computer glitch never updated it in our system. :| You should have your tea very soon!
User avatar
Mikael
 
Posts: 72
Joined: Jun 1st, '1
Location: New Joizy

Re: Web Reporting Issue

Postby Icculus » Jun 12th, '10, 20:26

the issue is resolved, thanks for the quick replies. apparently it was just a website mistake showing the order hadnt been shipped.
Icculus
 
Posts: 2
Joined: Jun 12th, '


Instant Messenger

Permissions
You cannot post new topics
You cannot reply to topics
You cannot edit your posts
You cannot delete your posts
You cannot post attachments
Navigation